<!DOCTYPE html>
<html lang="en-US"
	prefix="og: https://ogp.me/ns#" >
<head>
	<meta charset="UTF-8"/>
	<meta name="viewport" content="width=device-width, initial-scale=1">
	<link rel="profile" href="https://gmpg.org/xfn/11"/>
	<!-- JM Twitter Cards by Julien Maury 10.0.1 -->
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:creator" content="@chicitysports23">
<meta name="twitter:site" content="@chicitysports23">
<meta property="og:title" content="The Bear Front Podcast: Week 17 vs Minnesota">
<meta property="og:description" content="Following a rough Sunday night showing, the Bears head to Minnesota to wrap up the 2019 season against the Vikings. With a roster of backups taking the field for a resting Minnesota team, can the Bea">
<meta property="og:image" content="https://www.chicitysports.com/wp-content/uploads/2018/12/04/Bear-Front-Header-1.jpg">
<!-- /JM Twitter Cards by Julien Maury 10.0.1 -->
<title>The Bear Front Podcast: Week 17 vs Minnesota | CHI CITY SPORTS l Chicago Sports Blog - News - Forum - Fans - Rumors</title>

<!-- All in One SEO Pack 3.3.4 by Michael Torbert of Semper Fi Web Designob_start_detected [-1,-1] -->
<meta name="description"  content="Following a rough Sunday night showing, the Bears head to Minnesota to wrap up the 2019 season against the Vikings. With a roster of backups taking the field" />

<meta name="keywords"  content="chicago bears,minnesota vikings,nfl,football,week 17 nfl,bears,vikings,podcast,podcasts,the bear front" />

<script type="application/ld+json" class="aioseop-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.chicitysports.com/#organization","url":"https://www.chicitysports.com/","name":"CHI CITY SPORTS l Chicago Sports Blog - News - Forum - Fans - Rumors","sameAs":[],"logo":{"@type":"ImageObject","@id":"https://www.chicitysports.com/#logo","url":"https://www.chicitysports.com/wp-content/uploads/2018/09/27/cropped-chicitysportslogo2018.png","caption":""},"image":{"@id":"https://www.chicitysports.com/#logo"}},{"@type":"WebSite","@id":"https://www.chicitysports.com/#website","url":"https://www.chicitysports.com/","name":"CHI CITY SPORTS l Chicago Sports Blog - News - Forum - Fans - Rumors","publisher":{"@id":"https://www.chicitysports.com/#organization"}},{"@type":"WebPage","@id":"https://www.chicitysports.com/2019/12/27/the-bear-front-podcast-week-17-vs-minnesota-2/#webpage","url":"https://www.chicitysports.com/2019/12/27/the-bear-front-podcast-week-17-vs-minnesota-2/","inLanguage":"en-US","name":"The Bear Front Podcast: Week 17 vs Minnesota","isPartOf":{"@id":"https://www.chicitysports.com/#website"},"image":{"@type":"ImageObject","@id":"https://www.chicitysports.com/2019/12/27/the-bear-front-podcast-week-17-vs-minnesota-2/#primaryimage","url":"https://www.chicitysports.com/wp-content/uploads/2018/12/04/Bear-Front-Header-1.jpg","width":768,"height":432},"primaryImageOfPage":{"@id":"https://www.chicitysports.com/2019/12/27/the-bear-front-podcast-week-17-vs-minnesota-2/#primaryimage"},"datePublished":"2019-12-28T04:21:16-06:00","dateModified":"2019-12-28T04:21:19-06:00"},{"@type":"Article","@id":"https://www.chicitysports.com/2019/12/27/the-bear-front-podcast-week-17-vs-minnesota-2/#article","isPartOf":{"@id":"https://www.chicitysports.com/2019/12/27/the-bear-front-podcast-week-17-vs-minnesota-2/#webpage"},"author":{"@id":"https://www.chicitysports.com/author/stephen-johnson/#author"},"headline":"The Bear Front Podcast: Week 17 vs Minnesota","datePublished":"2019-12-28T04:21:16-06:00","dateModified":"2019-12-28T04:21:19-06:00","commentCount":0,"mainEntityOfPage":{"@id":"https://www.chicitysports.com/2019/12/27/the-bear-front-podcast-week-17-vs-minnesota-2/#webpage"},"publisher":{"@id":"https://www.chicitysports.com/#organization"},"articleSection":"BEARS, FEATURED, Podcasts, Chicago Bears, minnesota vikings, Podcast, PODCASTS, The Bear Front","image":{"@type":"ImageObject","@id":"https://www.chicitysports.com/2019/12/27/the-bear-front-podcast-week-17-vs-minnesota-2/#primaryimage","url":"https://www.chicitysports.com/wp-content/uploads/2018/12/04/Bear-Front-Header-1.jpg","width":768,"height":432}},{"@type":"Person","@id":"https://www.chicitysports.com/author/stephen-johnson/#author","name":"Stephen Johnson","sameAs":["stephen_roto"],"image":{"@type":"ImageObject","@id":"https://www.chicitysports.com/#personlogo","url":"https://secure.gravatar.com/avatar/3ff457af75d8629a0f3d3309828f2283?s=96&d=mm&r=g","width":96,"height":96,"caption":"Stephen Johnson"}}]}</script>
<link rel="canonical" href="https://www.chicitysports.com/2019/12/27/the-bear-front-podcast-week-17-vs-minnesota-2/" />
<meta property="og:type" content="article" />
<meta property="og:title" content="The Bear Front Podcast: Week 17 vs Minnesota" />
<meta property="og:description" content="The Bears head to Minnesota to wrap up the 2019 season against the Vikings. With a roster of backups taking the field for a resting Minnesota team, can the Bears take any solace in snagging a victory away from their NFC North foes on Sunday?" />
<meta property="og:url" content="https://www.chicitysports.com/2019/12/27/the-bear-front-podcast-week-17-vs-minnesota-2/" />
<meta property="og:site_name" content="ChiCitySports.com Chicago Sports Blog &amp; Forum" />
<meta property="og:image" content="https://www.chicitysports.com/wp-content/uploads/2018/12/04/Bear-Front-Header.jpg" />
<meta property="article:tag" content="chicago bears" />
<meta property="article:tag" content="minnesota vikings" />
<meta property="article:tag" content="nfl" />
<meta property="article:tag" content="football" />
<meta property="article:published_time" content="2019-12-28T04:21:16Z" />
<meta property="article:modified_time" content="2019-12-28T04:21:19Z" />
<meta property="og:image:secure_url" content="https://www.chicitysports.com/wp-content/uploads/2018/12/04/Bear-Front-Header.jpg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@ChiCitySports23" />
<meta name="twitter:creator" content="@stephen_roto" />
<meta name="twitter:domain" content="https://www.chicitysports.com/" />
<meta name="twitter:title" content="The Bear Front Podcast: Week 17 vs Minnesota" />
<meta name="twitter:description" content="The Bears head to Minnesota to wrap up the 2019 season against the Vikings. With a roster of backups taking the field for a resting Minnesota team, can the Bears take any solace in snagging a victory away from their NFC North foes on Sunday?" />
<meta name="twitter:image" content="https://www.chicitysports.com/wp-content/uploads/2018/12/04/Bear-Front-Header.jpg" />
<!-- All in One SEO Pack -->
<link rel='dns-prefetch' href='//platform-api.sharethis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="CHI CITY SPORTS l Chicago Sports Blog - News - Forum - Fans - Rumors &raquo; Feed" href="https://www.chicitysports.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="CHI CITY SPORTS l Chicago Sports Blog - News - Forum - Fans - Rumors &raquo; Comments Feed" href="https://www.chicitysports.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="CHI CITY SPORTS l Chicago Sports Blog - News - Forum - Fans - Rumors &raquo; The Bear Front Podcast: Week 17 vs Minnesota Comments Feed" href="https://www.chicitysports.com/2019/12/27/the-bear-front-podcast-week-17-vs-minnesota-2/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.chicitysports.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.chicitysports.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://www.chicitysports.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.6' type='text/css' media='all' />
<link rel='stylesheet' id='wc-gallery-style-css'  href='https://www.chicitysports.com/wp-content/plugins/wc-gallery/includes/css/style.css?ver=1.67' type='text/css' media='all' />
<link rel='stylesheet' id='wc-gallery-popup-style-css'  href='https://www.chicitysports.com/wp-content/plugins/wc-gallery/includes/css/magnific-popup.css?ver=1.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='wc-gallery-flexslider-style-css'  href='https://www.chicitysports.com/wp-content/plugins/wc-gallery/includes/vendors/flexslider/flexslider.css?ver=2.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='wc-gallery-owlcarousel-style-css'  href='https://www.chicitysports.com/wp-content/plugins/wc-gallery/includes/vendors/owlcarousel/assets/owl.carousel.css?ver=2.1.4' type='text/css' media='all' />
<link rel='stylesheet' id='wc-gallery-owlcarousel-theme-style-css'  href='https://www.chicitysports.com/wp-content/plugins/wc-gallery/includes/vendors/owlcarousel/assets/owl.theme.default.css?ver=2.1.4' type='text/css' media='all' />
<link rel='stylesheet' id='wp-pagenavi-css'  href='https://www.chicitysports.com/wp-content/plugins/wp-pagenavi/pagenavi-css.css?ver=2.70' type='text/css' media='all' />
<link rel='stylesheet' id='colormag_google_fonts-css'  href='//fonts.googleapis.com/css?family=Open+Sans%3A400%2C600&#038;ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='colormag_style-css'  href='https://www.chicitysports.com/wp-content/themes/colormag/style.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='colormag-fontawesome-css'  href='https://www.chicitysports.com/wp-content/themes/colormag/fontawesome/css/font-awesome.css?ver=4.2.1' type='text/css' media='all' />
<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://www.chicitysports.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.chicitysports.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<!--[if lte IE 8]>
<script type='text/javascript' src='https://www.chicitysports.com/wp-content/themes/colormag/js/html5shiv.min.js?ver=5.3.2'></script>
<![endif]-->
<script type='text/javascript' src='//platform-api.sharethis.com/js/sharethis.js#product=ga'></script>
<link rel='https://api.w.org/' href='https://www.chicitysports.com/wp-json/' />
<link rel='prev' title='White Sox Reportedly Reach Deal With Slugger Edwin Encarnacion' href='https://www.chicitysports.com/2019/12/26/white-sox-reportedly-reach-deal-with-slugger-edwin-encarnacion/' />
<meta name="generator" content="WordPress 5.3.2" />
<link rel='shortlink' href='https://www.chicitysports.com/?p=54256' />
<link rel="alternate" type="application/json+oembed" href="https://www.chicitysports.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.chicitysports.com%2F2019%2F12%2F27%2Fthe-bear-front-podcast-week-17-vs-minnesota-2%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.chicitysports.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.chicitysports.com%2F2019%2F12%2F27%2Fthe-bear-front-podcast-week-17-vs-minnesota-2%2F&#038;format=xml" />
          <style>
          .has-post-thumbnail img.wp-post-image, 
          .attachment-twentyseventeen-featured-image.wp-post-image { display: none !important; }          
          </style>		<!-- HappyForms global container -->
		<script type="text/javascript">HappyForms = {};</script>
		<!-- End of HappyForms global container -->
		<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>		<style type="text/css" id="wp-custom-css">
			.post-49182 {display:none;}		</style>
		</head>

<body data-rsssl=1 class="post-template-default single single-post postid-54256 single-format-standard wp-custom-logo  better-responsive-menu">


<div id="page" class="hfeed site">
	
	
	<header id="masthead" class="site-header clearfix ">
		<div id="header-text-nav-container" class="clearfix">

						<div class="news-bar">
				<div class="inner-wrap clearfix">
					
							<div class="breaking-news">
			<strong class="breaking-news-latest">Latest:</strong>
			<ul class="newsticker">
									<li>
						<a href="https://www.chicitysports.com/2019/12/27/the-bear-front-podcast-week-17-vs-minnesota-2/"
						   title="The Bear Front Podcast: Week 17 vs Minnesota">The Bear Front Podcast: Week 17 vs Minnesota</a>
					</li>
									<li>
						<a href="https://www.chicitysports.com/2019/12/26/white-sox-reportedly-reach-deal-with-slugger-edwin-encarnacion/"
						   title="White Sox Reportedly Reach Deal With Slugger Edwin Encarnacion">White Sox Reportedly Reach Deal With Slugger Edwin Encarnacion</a>
					</li>
									<li>
						<a href="https://www.chicitysports.com/2019/12/23/chicago-bears-in-the-race-for-2020-nfl-how-does-their-fate-look-like/"
						   title="Chicago Bears In The Race For 2020 NFL: How Does Their Fate Look Like?">Chicago Bears In The Race For 2020 NFL: How Does Their Fate Look Like?</a>
					</li>
									<li>
						<a href="https://www.chicitysports.com/2019/12/21/white-sox-agree-to-deal-with-dallas-keuchel/"
						   title="White Sox agree to deal with Dallas Keuchel">White Sox agree to deal with Dallas Keuchel</a>
					</li>
									<li>
						<a href="https://www.chicitysports.com/2019/12/19/the-bear-front-podcast-week-16-vs-kansas-city/"
						   title="The Bear Front Podcast: Week 16 vs Kansas City">The Bear Front Podcast: Week 16 vs Kansas City</a>
					</li>
							</ul>
		</div>
		
									</div>
			</div>
		
			
			
		<div class="inner-wrap">

			<div id="header-text-nav-wrap" class="clearfix">
				<div id="header-left-section">
											<div id="header-logo-image">
							<a href="https://www.chicitysports.com/" class="custom-logo-link" rel="home"><img width="150" height="120" src="https://www.chicitysports.com/wp-content/uploads/2018/09/27/cropped-chicitysportslogo2018.png" class="custom-logo" alt="CHI CITY SPORTS l Chicago Sports Blog &#8211; News &#8211; Forum &#8211; Fans &#8211; Rumors" /></a>						</div><!-- #header-logo-image -->
											<div id="header-text" class="">
													<h3 id="site-title">
								<a href="https://www.chicitysports.com/" title="CHI CITY SPORTS l Chicago Sports Blog &#8211; News &#8211; Forum &#8211; Fans &#8211; Rumors" rel="home">CHI CITY SPORTS l Chicago Sports Blog &#8211; News &#8211; Forum &#8211; Fans &#8211; Rumors</a>
							</h3>
																		<p id="site-description">Chicago Sports Blog &#8211; Latest News, Discussion, &amp; Rumors for the Bears, Bulls, Blackhawks, Cubs, White Sox, and Fire.</p>
						<!-- #site-description -->
					</div><!-- #header-text -->
				</div><!-- #header-left-section -->
				<div id="header-right-section">
									</div><!-- #header-right-section -->

			</div><!-- #header-text-nav-wrap -->

		</div><!-- .inner-wrap -->

		
			
			
		<nav id="site-navigation" class="main-navigation clearfix" role="navigation">
			<div class="inner-wrap clearfix">
				
					<div class="home-icon">
						<a href="https://www.chicitysports.com/" title="CHI CITY SPORTS l Chicago Sports Blog &#8211; News &#8211; Forum &#8211; Fans &#8211; Rumors"><i class="fa fa-home"></i></a>
					</div>

					
				<p class="menu-toggle"></p>
				<div class="menu-primary-container"><ul id="menu-menu" class="menu"><li id="menu-item-49172" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49172"><a title="Chicago Sports Forum" href="https://www.chicitysports.com/forums/">Message Board</a></li>
<li id="menu-item-49173" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49173"><a href="https://www.chicitysports.com/contact/">Contact Us</a></li>
<li id="menu-item-49174" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49174"><a href="https://www.chicitysports.com/about/">About CCS</a></li>
<li id="menu-item-49195" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-49195"><a href="https://www.chicitysports.com/forum/forumdisplay.php/4-Chicago-Sports-Discussion">Team Forums</a>
<ul class="sub-menu">
	<li id="menu-item-49196" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49196"><a href="https://www.chicitysports.com/forum/forumdisplay.php/5-Chicago-Bears-Forum">Bears Team Forum</a></li>
	<li id="menu-item-49197" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49197"><a href="https://www.chicitysports.com/forum/forumdisplay.php/6-Chicago-Bulls-Forum">Bulls Team Forum</a></li>
	<li id="menu-item-49198" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49198"><a href="https://www.chicitysports.com/forum/forumdisplay.php/9-Chicago-Blackhawks-Forum">Blackhawks Team Forum</a></li>
	<li id="menu-item-49199" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49199"><a href="https://www.chicitysports.com/forum/forumdisplay.php/7-Chicago-Cubs-Forum">Cubs Team Forum</a></li>
	<li id="menu-item-49200" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49200"><a href="https://www.chicitysports.com/forum/forumdisplay.php/8-Chicago-White-Sox-Forum">White Sox Team Forum</a></li>
	<li id="menu-item-49201" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49201"><a href="https://www.chicitysports.com/forum/forumdisplay.php/35-Chicago-Fire-Forum">Fire Team Forum</a></li>
</ul>
</li>
<li id="menu-item-50657" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-50657"><a href="https://www.chicitysports.com/podcasts/">Podcasts</a></li>
<li id="menu-item-52851" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-52851"><a href="https://www.chicitysports.com/chicago-sports-schedule/">Chicago Sports Schedule</a>
<ul class="sub-menu">
	<li id="menu-item-52852" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-52852"><a href="https://www.chicitysports.com/chicago-sports-schedule/chicago-bears-schedule/">Chicago Bears Schedule</a></li>
	<li id="menu-item-52860" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-52860"><a href="https://www.chicitysports.com/chicago-sports-schedule/chicago-blackhawks-schedule/">Chicago Blackhawks Schedule</a></li>
	<li id="menu-item-52856" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-52856"><a href="https://www.chicitysports.com/chicago-sports-schedule/chicago-bulls-schedule/">Chicago Bulls Schedule</a></li>
	<li id="menu-item-52866" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-52866"><a href="https://www.chicitysports.com/chicago-sports-schedule/chicago-cubs-schedule/">Chicago Cubs Schedule</a></li>
	<li id="menu-item-52867" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-52867"><a href="https://www.chicitysports.com/chicago-sports-schedule/chicago-white-sox-schedule/">Chicago White Sox schedule</a></li>
</ul>
</li>
<li id="menu-item-53040" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-53040"><a href="https://chicitysports.myshopify.com/">ChiCitySports Shop</a></li>
<li id="menu-item-53201" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-53201"><a href="https://www.sportsbookreview.com/betting-odds/">Betting Odds</a></li>
</ul></div>
				
									<i class="fa fa-search search-top"></i>
					<div class="search-form-top">
						<form action="https://www.chicitysports.com/" class="search-form searchform clearfix" method="get">
   <div class="search-wrap">
      <input type="text" placeholder="Search" class="s field" name="s">
      <button class="search-icon" type="submit"></button>
   </div>
</form><!-- .searchform -->					</div>
							</div>
		</nav>

		
		</div><!-- #header-text-nav-container -->

		
	</header>

		
	<div id="main" class="clearfix">
		<div class="inner-wrap clearfix">

	
	<div id="primary">
		<div id="content" class="clearfix">

			
				
<article id="post-54256" class="post-54256 post type-post status-publish format-standard has-post-thumbnail hentry category-chicagobears category-featured category-ccs-podcasts tag-chicago-bears tag-minnesota-vikings tag-podcast tag-podcasts tag-the-bear-front">
	
   
         <div class="featured-image">
               <img width="768" height="432" src="https://www.chicitysports.com/wp-content/uploads/2018/12/04/Bear-Front-Header-1.jpg" class="attachment-colormag-featured-image size-colormag-featured-image wp-post-image" alt="" srcset="https://www.chicitysports.com/wp-content/uploads/2018/12/04/Bear-Front-Header-1.jpg 768w, https://www.chicitysports.com/wp-content/uploads/2018/12/04/Bear-Front-Header-1-300x169.jpg 300w, https://www.chicitysports.com/wp-content/uploads/2018/12/04/Bear-Front-Header-1-250x141.jpg 250w, https://www.chicitysports.com/wp-content/uploads/2018/12/04/Bear-Front-Header-1-550x309.jpg 550w, https://www.chicitysports.com/wp-content/uploads/2018/12/04/Bear-Front-Header-1-320x180.jpg 320w, https://www.chicitysports.com/wp-content/uploads/2018/12/04/Bear-Front-Header-1-533x300.jpg 533w" sizes="(max-width: 768px) 100vw, 768px" />            </div>
   
   <div class="article-content clearfix">

   
   <div class="above-entry-meta"><span class="cat-links"><a href="https://www.chicitysports.com/category/chicagobears/" style="background:#0e263e" rel="category tag">BEARS</a>&nbsp;<a href="https://www.chicitysports.com/category/featured/"  rel="category tag">FEATURED</a>&nbsp;<a href="https://www.chicitysports.com/category/ccs-podcasts/"  rel="category tag">Podcasts</a>&nbsp;</span></div>
      <header class="entry-header">
   		<h1 class="entry-title">
   			The Bear Front Podcast: Week 17 vs Minnesota   		</h1>
   	</header>

   	<div class="below-entry-meta">
			<span class="posted-on"><a href="https://www.chicitysports.com/2019/12/27/the-bear-front-podcast-week-17-vs-minnesota-2/" title="10:21 PM" rel="bookmark"><i class="fa fa-calendar-o"></i> <time class="entry-date published" datetime="2019-12-27T22:21:16-06:00">December 27, 2019</time><time class="updated" datetime="2019-12-27T22:21:19-06:00">December 27, 2019</time></a></span>
			<span class="byline">
				<span class="author vcard">
					<i class="fa fa-user"></i>
					<a class="url fn n"
					   href="https://www.chicitysports.com/author/stephen-johnson/"
					   title="Stephen Johnson">Stephen Johnson					</a>
				</span>
			</span>

							<span class="comments"><a href="https://www.chicitysports.com/2019/12/27/the-bear-front-podcast-week-17-vs-minnesota-2/#respond"><i class="fa fa-comment"></i> 0 Comments</a></span>
			<span class="tag-links"><i class="fa fa-tags"></i><a href="https://www.chicitysports.com/tag/chicago-bears/" rel="tag">Chicago Bears</a>, <a href="https://www.chicitysports.com/tag/minnesota-vikings/" rel="tag">minnesota vikings</a>, <a href="https://www.chicitysports.com/tag/podcast/" rel="tag">Podcast</a>, <a href="https://www.chicitysports.com/tag/podcasts/" rel="tag">PODCASTS</a>, <a href="https://www.chicitysports.com/tag/the-bear-front/" rel="tag">The Bear Front</a></span></div>
   	<div class="entry-content clearfix">
   		
<p>Following a rough Sunday night showing, the Bears head to Minnesota to wrap up the 2019 season against the Vikings. With a roster of backups taking the field for a resting Minnesota team, can the Bears take any solace in snagging a victory away from their NFC North foes on Sunday? The guys discuss and more. PLUS, the winner of the Fanatics Bears hat is announced!</p>


<iframe src="https://widget.spreaker.com/player?episode_id=21128903&amp;theme=light&amp;playlist=false&amp;playlist-continuous=false&amp;chapters-image=true&amp;autoplay=false&amp;live-autoplay=false&amp;episode_image_position=right&amp;hide-likes=false&amp;hide-comments=false&amp;hide-sharing=false&amp;hide-logo=false&amp;hide-download=true" width="100%" height="200px" frameborder="0"></iframe>



<div class="wp-block-image"><figure class="aligncenter size-medium"><a href="https://itunes.apple.com/us/podcast/the-bear-front/id1438696006?mt=2"><img src="https://www.chicitysports.com/wp-content/uploads/2018/12/04/Listen-on-Apple-Podcasts-badge-300x77.jpg" alt="" class="wp-image-51272" srcset="https://www.chicitysports.com/wp-content/uploads/2018/12/04/Listen-on-Apple-Podcasts-badge-300x77.jpg 300w, https://www.chicitysports.com/wp-content/uploads/2018/12/04/Listen-on-Apple-Podcasts-badge-768x197.jpg 768w, https://www.chicitysports.com/wp-content/uploads/2018/12/04/Listen-on-Apple-Podcasts-badge-1024x262.jpg 1024w, https://www.chicitysports.com/wp-content/uploads/2018/12/04/Listen-on-Apple-Podcasts-badge-250x64.jpg 250w, https://www.chicitysports.com/wp-content/uploads/2018/12/04/Listen-on-Apple-Podcasts-badge-550x141.jpg 550w, https://www.chicitysports.com/wp-content/uploads/2018/12/04/Listen-on-Apple-Podcasts-badge-800x205.jpg 800w, https://www.chicitysports.com/wp-content/uploads/2018/12/04/Listen-on-Apple-Podcasts-badge-703x180.jpg 703w, https://www.chicitysports.com/wp-content/uploads/2018/12/04/Listen-on-Apple-Podcasts-badge-1171x300.jpg 1171w, https://www.chicitysports.com/wp-content/uploads/2018/12/04/Listen-on-Apple-Podcasts-badge-1952x500.jpg 1952w" sizes="(max-width: 300px) 100vw, 300px" /></a></figure></div>



<div class="wp-block-image"><figure class="aligncenter size-medium"><a href="https://playmusic.app.goo.gl/?ibi=com.google.PlayMusic&amp;isi=691797987&amp;ius=googleplaymusic&amp;apn=com.google.android.music&amp;link=https://play.google.com/music/m/Ixu266wx3dlkhaljrm32eyfbrba?t%3DThe_Bear_Front%26pcampaignid%3DMKT-na-all-co-pr-mu-pod-16"><img src="https://www.chicitysports.com/wp-content/uploads/2018/12/04/google-play-badge-1-300x110.png" alt="" class="wp-image-51273" srcset="https://www.chicitysports.com/wp-content/uploads/2018/12/04/google-play-badge-1-300x110.png 300w, https://www.chicitysports.com/wp-content/uploads/2018/12/04/google-play-badge-1-250x92.png 250w, https://www.chicitysports.com/wp-content/uploads/2018/12/04/google-play-badge-1.png 455w" sizes="(max-width: 300px) 100vw, 300px" /></a></figure></div>
   	</div>

   </div>

	</article>

			
		</div><!-- #content -->

      
		<ul class="default-wp-page clearfix">
			<li class="previous"><a href="https://www.chicitysports.com/2019/12/26/white-sox-reportedly-reach-deal-with-slugger-edwin-encarnacion/" rel="prev"><span class="meta-nav">&larr;</span> White Sox Reportedly Reach Deal With Slugger Edwin Encarnacion</a></li>
			<li class="next"></li>
		</ul>
	
               <div class="author-box">
            <div class="author-img"><img alt='' src='https://secure.gravatar.com/avatar/3ff457af75d8629a0f3d3309828f2283?s=100&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/3ff457af75d8629a0f3d3309828f2283?s=200&#038;d=mm&#038;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' /></div>
               <h4 class="author-name">Stephen Johnson</h4>
               <p class="author-description">Host of ChiCitySports’ The Bear Front podcast, Stephen previously spent 8 years with ESPN Radio and as a TV reporter. He is an avid fantasy sports player and is a former Fantasy Football Expert for Chicago’s 670am The Score.</p>
         </div>
      
      
      
<div id="comments" class="comments-area">

	
	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2019/12/27/the-bear-front-podcast-week-17-vs-minnesota-2/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.chicitysports.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='54256' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="a1fe700ddb" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="213"/></p></form>	</div><!-- #respond -->
	
</div><!-- #comments -->
	</div><!-- #primary -->

	
<div id="secondary">
			
		<aside id="media_image-2" class="widget widget_media_image clearfix"><h3 class="widget-title"><span>Write for ChiCitySports!</span></h3><a href="https://www.chicitysports.com/contact/"><img width="290" height="143" src="https://www.chicitysports.com/wp-content/uploads/2019/05/08/A0idSQ4.png" class="image wp-image-52594  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://www.chicitysports.com/wp-content/uploads/2019/05/08/A0idSQ4.png 290w, https://www.chicitysports.com/wp-content/uploads/2019/05/08/A0idSQ4-250x123.png 250w" sizes="(max-width: 290px) 100vw, 290px" /></a></aside><aside id="custom_html-2" class="widget_text widget widget_custom_html clearfix"><div class="textwidget custom-html-widget"><script src="//ap.lijit.com/www/delivery/fpi.js?z=383907&width=300&height=250"></script> </div></aside><aside id="custom_html-3" class="widget_text widget widget_custom_html clearfix"><h3 class="widget-title"><span>Chicago Sports Schedule</span></h3><div class="textwidget custom-html-widget"> <div class="stanzacal" data-stanzacal="chicitysports" data-site="chicitysports" data-width="300px" data-height="800px" ></div>

<script src="https://dff2h0hbfv6w4.cloudfront.net/scripts/embed-stanzacal-v1.js" type="text/javascript"></script></div></aside><aside id="custom_html-4" class="widget_text widget widget_custom_html clearfix"><h3 class="widget-title"><span>Shop and Support CCS!</span></h3><div class="textwidget custom-html-widget"><a target="_blank" href="https://shareasale.com/r.cfm?b=1377849&amp;u=1291289&amp;m=73502&amp;urllink=&amp;afftrack=" rel="noopener noreferrer"><img src="https://static.shareasale.com/image/73502/PATCHJERSEY_CS_300x250_BEAR.jpg" border="0" /></a></div></aside><aside id="custom_html-5" class="widget_text widget widget_custom_html clearfix"><div class="textwidget custom-html-widget"><script src="//ap.lijit.com/www/delivery/fpi.js?z=383907&width=300&height=250"></script> </div></aside><aside id="text-6" class="widget widget_text clearfix">			<div class="textwidget"><p>&#8220;New betting sites and latest bookmakers in the betting market.All are verified, secured and trusted so check out this best new <a href="https://www.premiumbookmakers.com/" target="_blank" rel="noopener noreferrer" data-saferedirecturl="https://www.google.com/url?q=https://www.premiumbookmakers.com/&amp;source=gmail&amp;ust=1567209009335000&amp;usg=AFQjCNHkd1P2ptzttFQuCxjGM4NVDfwkdg">Betting Sites</a> &#8220;</p>
</div>
		</aside>
	</div>
	

</div><!-- .inner-wrap -->
</div><!-- #main -->

	<div class="advertisement_above_footer">
		<div class="inner-wrap">
			<aside id="media_image-3" class="widget widget_media_image clearfix"><a href="https://sports.betway.com/en/sports"><img width="300" height="37" src="https://www.chicitysports.com/wp-content/uploads/2019/12/20/sports-betting-site-betway-728x90-1-300x37.jpg" class="image wp-image-54232  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" srcset="https://www.chicitysports.com/wp-content/uploads/2019/12/20/sports-betting-site-betway-728x90-1-300x37.jpg 300w, https://www.chicitysports.com/wp-content/uploads/2019/12/20/sports-betting-site-betway-728x90-1-250x31.jpg 250w, https://www.chicitysports.com/wp-content/uploads/2019/12/20/sports-betting-site-betway-728x90-1-550x68.jpg 550w, https://www.chicitysports.com/wp-content/uploads/2019/12/20/sports-betting-site-betway-728x90-1.jpg 728w" sizes="(max-width: 300px) 100vw, 300px" /></a></aside>		</div>
	</div>



<footer id="colophon" class="clearfix ">
	
<div class="footer-widgets-wrapper">
	<div class="inner-wrap">
		<div class="footer-widgets-area clearfix">
         <div class="tg-footer-main-widget">
   			<div class="tg-first-footer-widget">
   				<aside id="text-5" class="widget widget_text clearfix">			<div class="textwidget"><p>ChiCitySports was founded in 2010 as a all-Chicago Sports blog and has grown into one of the largest Chicago Sports forums on the internet. We cover Chicago Sports the way the fan wants it covered.</p>
</div>
		</aside>   			</div>
         </div>
         <div class="tg-footer-other-widgets">
   			<div class="tg-second-footer-widget">
   				   			</div>
            <div class="tg-third-footer-widget">
               <aside id="recent-comments-3" class="widget widget_recent_comments clearfix"><h3 class="widget-title"><span>Recent Comments</span></h3><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">Alex</span> on <a href="https://www.chicitysports.com/2019/12/26/white-sox-reportedly-reach-deal-with-slugger-edwin-encarnacion/#comment-229475">White Sox Reportedly Reach Deal With Slugger Edwin Encarnacion</a></li><li class="recentcomments"><span class="comment-author-link">Alan</span> on <a href="https://www.chicitysports.com/2019/12/26/white-sox-reportedly-reach-deal-with-slugger-edwin-encarnacion/#comment-229474">White Sox Reportedly Reach Deal With Slugger Edwin Encarnacion</a></li><li class="recentcomments"><span class="comment-author-link">John</span> on <a href="https://www.chicitysports.com/2019/11/08/should-the-chicago-blackhawks-fire-jeremy-colliton/#comment-229140">Should the Chicago Blackhawks Fire Jeremy Colliton?</a></li><li class="recentcomments"><span class="comment-author-link">Fred Plese</span> on <a href="https://www.chicitysports.com/2019/12/09/report-cubs-phillies-have-discussed-kris-bryant-trade/#comment-228978">Report: Cubs, Phillies have discussed Kris Bryant trade</a></li></ul></aside>            </div>
            <div class="tg-fourth-footer-widget">
               <aside id="linkcat-2" class="widget widget_links clearfix"><h3 class="widget-title"><span>Links</span></h3>
	<ul class='xoxo blogroll'>
<li><a href="http://www.beargoggleson.com">BearGogglesOn</a></li>
<li><a href="https://www.chicitysports.com/forum/forumdisplay.php/5-Chicago-Bears-Forum" title="Chicago Bears Fan Message Board">Bears Message Board</a></li>
<li><a href="http://www.bigtimegameboards.com/" title="Quality Custom Cornhole Boards">BigTimeGameBoards.Com</a></li>
<li><a href="https://www.chicitysports.com/forum/forumdisplay.php/9-Chicago-Blackhawks-Forum" title="Chicago Blackhawks Fan Message Board">Blackhawks Message Board</a></li>
<li><a href="https://www.chicitysports.com/forum/forumdisplay.php/6-Chicago-Bulls-Forum" title="Chicago Bulls Fan Message Board">Bulls Message Board</a></li>
<li><a href="http://www.reddit.com/r/chibears" title="Reddit&#8217;s Chicago Bears Community">Chicago Bears on Reddit</a></li>
<li><a href="http://www.chicagotribune.com/sports/">Chicago Tribune Sports</a></li>
<li><a href="http://www.chitownclothing.com" title="Chicago Sports Clothing. ">Chitown Sports Clothing</a></li>
<li><a href="https://www.chicitysports.com/forum/forumdisplay.php/7-Chicago-Cubs-Forum" title="Chicago Cubs Fan Message Board">Cubs Message Board</a></li>
<li><a href="http://www.dabearnecessities.com/">Da Bear Necessities</a></li>
<li><a href="https://www.chicitysports.com/forum/forumdisplay.php/35-Chicago-Fire-Forum" title="Chicago Fire Fan Message Board">Fire Message Board</a></li>
<li><a href="http://www.gamedaychitown.com">GameDay Chitown</a></li>
<li><a href="https://www.chicitysports.com/forum/forumdisplay.php/8-Chicago-White-Sox-Forum" title="Chicago White Sox Fan Message Board">White Sox Message Board</a></li>

	</ul>
</aside>
            </div>
         </div>
		</div>
	</div>
</div>	<div class="footer-socket-wrapper clearfix">
		<div class="inner-wrap">
			<div class="footer-socket-area">
				<div class="footer-socket-right-section">
									</div>

				<div class="footer-socket-left-section">
					<div class="copyright">Copyright &copy; 2019 <a href="https://www.chicitysports.com/" title="CHI CITY SPORTS l Chicago Sports Blog &#8211; News &#8211; Forum &#8211; Fans &#8211; Rumors" ><span>CHI CITY SPORTS l Chicago Sports Blog &#8211; News &#8211; Forum &#8211; Fans &#8211; Rumors</span></a>. All rights reserved.<br>Theme: ColorMag by <a href="https://themegrill.com/themes/colormag" target="_blank" title="ThemeGrill" rel="author"><span>ThemeGrill</span></a>. Powered by <a href="https://wordpress.org" target="_blank" title="WordPress"><span>WordPress</span></a>.</div>				</div>
			</div>
		</div>
	</div>
</footer>

<a href="#masthead" id="scroll-up"><i class="fa fa-chevron-up"></i></a>

</div><!-- #page -->
  <!-- VigLink: http://viglink.com -->
  <script type="text/javascript">
    var vglnk = { key: 'ff3e699c7a374298785f40574a4881a5' };

    (function(d, t) {
      var s = d.createElement(t); s.type = 'text/javascript'; s.async = true;
      s.src = '//cdn.viglink.com/api/vglnk.js?key=' + vglnk.key;
      var r = d.getElementsByTagName(t)[0]; r.parentNode.insertBefore(s, r);
    }(document, 'script'));
  </script>
  <!-- end VigLink -->
<script>
    jQuery(document).ready(function () {
		jQuery.post('https://www.chicitysports.com?ga_action=googleanalytics_get_script', {action: 'googleanalytics_get_script'}, function(response) {
			var s = document.createElement("script");
			s.type = "text/javascript";
			s.innerHTML = response;
			jQuery("head").append(s);
		});
    });
</script><script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.chicitysports.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.chicitysports.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.6'></script>
<script type='text/javascript' src='https://www.chicitysports.com/wp-content/themes/colormag/js/jquery.bxslider.min.js?ver=4.2.10'></script>
<script type='text/javascript' src='https://www.chicitysports.com/wp-content/themes/colormag/js/navigation.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://www.chicitysports.com/wp-content/themes/colormag/js/colormag-custom.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://www.chicitysports.com/wp-content/themes/colormag/js/news-ticker/jquery.newsTicker.min.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://www.chicitysports.com/wp-content/themes/colormag/js/sticky/jquery.sticky.js?ver=20150309'></script>
<script type='text/javascript' src='https://www.chicitysports.com/wp-content/themes/colormag/js/fitvids/jquery.fitvids.js?ver=20150311'></script>
<script type='text/javascript' src='https://www.chicitysports.com/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
<script async="async" type='text/javascript' src='https://www.chicitysports.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.3'></script>
</body>
</html>

<!--
Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Object Caching 115/128 objects using memcache
Page Caching using memcache 
Database Caching using memcache

Served from: www.chicitysports.com @ 2019-12-27 22:21:37 by W3 Total Cache
-->