<!DOCTYPE html>
<html lang="en-US"
	prefix="og: https://ogp.me/ns#" >
<head>
	<meta charset="UTF-8"/>
	<meta name="viewport" content="width=device-width, initial-scale=1">
	<link rel="profile" href="https://gmpg.org/xfn/11"/>
	<!-- JM Twitter Cards by Julien Maury 10.0.1 -->
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:creator" content="@chicitysports23">
<meta name="twitter:site" content="@chicitysports23">
<meta property="og:title" content="The Best of the Best in Professional Betting">
<meta property="og:description" content="In the world of gambling, there are names and faces that stand out to even the most inexperienced of bettors. The industry is worth approximately £8 billion in the UK alone, meaning the professionals">
<meta property="og:image" content="https://www.chicitysports.com/wp-content/uploads/2020/02/12/Gambling.jpg">
<!-- /JM Twitter Cards by Julien Maury 10.0.1 -->
<title>The Best of the Best in Professional Betting | CHI CITY SPORTS l Chicago Sports Blog - News - Forum - Fans - Rumors</title>

<!-- All in One SEO Pack 3.3.4 by Michael Torbert of Semper Fi Web Designob_start_detected [-1,-1] -->
<meta name="description"  content="In the world of gambling, there are names and faces that stand out to even the most inexperienced of bettors. The industry is worth approximately £8 billion in" />

<meta name="keywords"  content="gambling" />

<script type="application/ld+json" class="aioseop-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.chicitysports.com/#organization","url":"https://www.chicitysports.com/","name":"CHI CITY SPORTS l Chicago Sports Blog - News - Forum - Fans - Rumors","sameAs":[],"logo":{"@type":"ImageObject","@id":"https://www.chicitysports.com/#logo","url":"https://www.chicitysports.com/wp-content/uploads/2020/01/20/cropped-cropped-chicitysportslogo2018_ab6a2d34c10e806b8f835e04c49aa5b7.png","caption":""},"image":{"@id":"https://www.chicitysports.com/#logo"}},{"@type":"WebSite","@id":"https://www.chicitysports.com/#website","url":"https://www.chicitysports.com/","name":"CHI CITY SPORTS l Chicago Sports Blog - News - Forum - Fans - Rumors","publisher":{"@id":"https://www.chicitysports.com/#organization"}},{"@type":"WebPage","@id":"https://www.chicitysports.com/2020/02/12/the-best-of-the-best-in-professional-betting/#webpage","url":"https://www.chicitysports.com/2020/02/12/the-best-of-the-best-in-professional-betting/","inLanguage":"en-US","name":"The Best of the Best in Professional Betting","isPartOf":{"@id":"https://www.chicitysports.com/#website"},"image":{"@type":"ImageObject","@id":"https://www.chicitysports.com/2020/02/12/the-best-of-the-best-in-professional-betting/#primaryimage","url":"https://www.chicitysports.com/wp-content/uploads/2020/02/12/Gambling.jpg","width":1600,"height":902},"primaryImageOfPage":{"@id":"https://www.chicitysports.com/2020/02/12/the-best-of-the-best-in-professional-betting/#primaryimage"},"datePublished":"2020-02-12T20:19:01-06:00","dateModified":"2020-02-12T20:19:40-06:00"},{"@type":"Article","@id":"https://www.chicitysports.com/2020/02/12/the-best-of-the-best-in-professional-betting/#article","isPartOf":{"@id":"https://www.chicitysports.com/2020/02/12/the-best-of-the-best-in-professional-betting/#webpage"},"author":{"@id":"https://www.chicitysports.com/author/ned-d/#author"},"headline":"The Best of the Best in Professional Betting","datePublished":"2020-02-12T20:19:01-06:00","dateModified":"2020-02-12T20:19:40-06:00","commentCount":0,"mainEntityOfPage":{"@id":"https://www.chicitysports.com/2020/02/12/the-best-of-the-best-in-professional-betting/#webpage"},"publisher":{"@id":"https://www.chicitysports.com/#organization"},"articleSection":"OTHER, Gambling","image":{"@type":"ImageObject","@id":"https://www.chicitysports.com/2020/02/12/the-best-of-the-best-in-professional-betting/#primaryimage","url":"https://www.chicitysports.com/wp-content/uploads/2020/02/12/Gambling.jpg","width":1600,"height":902}},{"@type":"Person","@id":"https://www.chicitysports.com/author/ned-d/#author","name":"CCS Staff","sameAs":[],"image":{"@type":"ImageObject","@id":"https://www.chicitysports.com/#personlogo","url":"https://secure.gravatar.com/avatar/345cafdd01ee1a2d13af5daff17eef59?s=96&d=mm&r=g","width":96,"height":96,"caption":"CCS Staff"}}]}</script>
<link rel="canonical" href="https://www.chicitysports.com/2020/02/12/the-best-of-the-best-in-professional-betting/" />
<meta property="og:type" content="article" />
<meta property="og:title" content="The Best of the Best in Professional Betting | CHI CITY SPORTS l Chicago Sports Blog - News - Forum - Fans - Rumors" />
<meta property="og:description" content="In the world of gambling, there are names and faces that stand out to even the most inexperienced of bettors. The industry is worth approximately £8 billion in the UK alone, meaning the professionals" />
<meta property="og:url" content="https://www.chicitysports.com/2020/02/12/the-best-of-the-best-in-professional-betting/" />
<meta property="og:site_name" content="ChiCitySports.com Chicago Sports Blog &amp; Forum" />
<meta property="og:image" content="https://www.chicitysports.com/wp-content/uploads/2020/02/12/Gambling-1024x577.jpg" />
<meta property="article:published_time" content="2020-02-12T20:19:01Z" />
<meta property="article:modified_time" content="2020-02-12T20:19:40Z" />
<meta property="og:image:secure_url" content="https://www.chicitysports.com/wp-content/uploads/2020/02/12/Gambling-1024x577.jpg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@ChiCitySports23" />
<meta name="twitter:domain" content="https://www.chicitysports.com/" />
<meta name="twitter:title" content="The Best of the Best in Professional Betting | CHI CITY SPORTS l Chica" />
<meta name="twitter:description" content="In the world of gambling, there are names and faces that stand out to even the most inexperienced of bettors. The industry is worth approximately £8 billion in the UK alone, meaning the professionals" />
<meta name="twitter:image" content="https://www.chicitysports.com/wp-content/uploads/2020/02/12/Gambling-1024x577.jpg" />
<!-- All in One SEO Pack -->
<link rel='dns-prefetch' href='//platform-api.sharethis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="CHI CITY SPORTS l Chicago Sports Blog - News - Forum - Fans - Rumors &raquo; Feed" href="https://www.chicitysports.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="CHI CITY SPORTS l Chicago Sports Blog - News - Forum - Fans - Rumors &raquo; Comments Feed" href="https://www.chicitysports.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="CHI CITY SPORTS l Chicago Sports Blog - News - Forum - Fans - Rumors &raquo; The Best of the Best in Professional Betting Comments Feed" href="https://www.chicitysports.com/2020/02/12/the-best-of-the-best-in-professional-betting/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.chicitysports.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.chicitysports.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://www.chicitysports.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.6' type='text/css' media='all' />
<link rel='stylesheet' id='wc-gallery-style-css'  href='https://www.chicitysports.com/wp-content/plugins/wc-gallery/includes/css/style.css?ver=1.67' type='text/css' media='all' />
<link rel='stylesheet' id='wc-gallery-popup-style-css'  href='https://www.chicitysports.com/wp-content/plugins/wc-gallery/includes/css/magnific-popup.css?ver=1.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='wc-gallery-flexslider-style-css'  href='https://www.chicitysports.com/wp-content/plugins/wc-gallery/includes/vendors/flexslider/flexslider.css?ver=2.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='wc-gallery-owlcarousel-style-css'  href='https://www.chicitysports.com/wp-content/plugins/wc-gallery/includes/vendors/owlcarousel/assets/owl.carousel.css?ver=2.1.4' type='text/css' media='all' />
<link rel='stylesheet' id='wc-gallery-owlcarousel-theme-style-css'  href='https://www.chicitysports.com/wp-content/plugins/wc-gallery/includes/vendors/owlcarousel/assets/owl.theme.default.css?ver=2.1.4' type='text/css' media='all' />
<link rel='stylesheet' id='wp-pagenavi-css'  href='https://www.chicitysports.com/wp-content/plugins/wp-pagenavi/pagenavi-css.css?ver=2.70' type='text/css' media='all' />
<link rel='stylesheet' id='colormag_google_fonts-css'  href='//fonts.googleapis.com/css?family=Open+Sans%3A400%2C600&#038;ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='colormag_style-css'  href='https://www.chicitysports.com/wp-content/themes/colormag/style.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='colormag-fontawesome-css'  href='https://www.chicitysports.com/wp-content/themes/colormag/fontawesome/css/font-awesome.css?ver=4.2.1' type='text/css' media='all' />
<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://www.chicitysports.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.chicitysports.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<!--[if lte IE 8]>
<script type='text/javascript' src='https://www.chicitysports.com/wp-content/themes/colormag/js/html5shiv.min.js?ver=5.3.2'></script>
<![endif]-->
<script type='text/javascript' src='//platform-api.sharethis.com/js/sharethis.js#product=ga'></script>
<link rel='https://api.w.org/' href='https://www.chicitysports.com/wp-json/' />
<link rel='prev' title='2020 PECOTA Projections Released; Where Do the White Sox Stand?' href='https://www.chicitysports.com/2020/02/11/2020-pecota-projections-released-where-do-the-white-sox-stand/' />
<link rel='next' title='Oilers deliver second-consecutive loss to Blackhawks' href='https://www.chicitysports.com/2020/02/12/oilers-deliver-second-consecutive-loss-to-blackhawks/' />
<meta name="generator" content="WordPress 5.3.2" />
<link rel='shortlink' href='https://www.chicitysports.com/?p=54627' />
<link rel="alternate" type="application/json+oembed" href="https://www.chicitysports.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.chicitysports.com%2F2020%2F02%2F12%2Fthe-best-of-the-best-in-professional-betting%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.chicitysports.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.chicitysports.com%2F2020%2F02%2F12%2Fthe-best-of-the-best-in-professional-betting%2F&#038;format=xml" />
		<script>
			document.documentElement.className = document.documentElement.className.replace( 'no-js', 'js' );
		</script>
				<style>
			.no-js img.lazyload { display: none; }
			figure.wp-block-image img.lazyloading { min-width: 150px; }
							.lazyload, .lazyloading { opacity: 0; }
				.lazyloaded {
					opacity: 1;
					transition: opacity 400ms;
					transition-delay: 0ms;
				}
					</style>
		<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>		<style type="text/css" id="wp-custom-css">
			.post-49182 {display:none;}		</style>
		</head>

<body data-rsssl=1 class="post-template-default single single-post postid-54627 single-format-standard wp-custom-logo  better-responsive-menu">



<div id="page" class="hfeed site">
	<a class="skip-link screen-reader-text" href="#main">Skip to content</a>

	
	
	<header id="masthead" class="site-header clearfix ">
		<div id="header-text-nav-container" class="clearfix">

						<div class="news-bar">
				<div class="inner-wrap clearfix">
					
							<div class="breaking-news">
			<strong class="breaking-news-latest">Latest:</strong>
			<ul class="newsticker">
									<li>
						<a href="https://www.chicitysports.com/2020/02/12/oilers-deliver-second-consecutive-loss-to-blackhawks/"
						   title="Oilers deliver second-consecutive loss to Blackhawks">Oilers deliver second-consecutive loss to Blackhawks</a>
					</li>
									<li>
						<a href="https://www.chicitysports.com/2020/02/12/the-best-of-the-best-in-professional-betting/"
						   title="The Best of the Best in Professional Betting">The Best of the Best in Professional Betting</a>
					</li>
									<li>
						<a href="https://www.chicitysports.com/2020/02/11/2020-pecota-projections-released-where-do-the-white-sox-stand/"
						   title="2020 PECOTA Projections Released; Where Do the White Sox Stand?">2020 PECOTA Projections Released; Where Do the White Sox Stand?</a>
					</li>
									<li>
						<a href="https://www.chicitysports.com/2020/02/11/best-idea-ever-girl-scouts-sell-cookies-outside-of-marijuana-dispensaries/"
						   title="Best Idea Ever? Girl Scouts sell cookies outside of Marijuana Dispensaries">Best Idea Ever? Girl Scouts sell cookies outside of Marijuana Dispensaries</a>
					</li>
									<li>
						<a href="https://www.chicitysports.com/2020/02/10/should-the-chicago-bears-take-a-serious-look-at-philip-rivers/"
						   title="Should the Chicago Bears Take a Serious Look at Philip Rivers?">Should the Chicago Bears Take a Serious Look at Philip Rivers?</a>
					</li>
							</ul>
		</div>
		
									</div>
			</div>
		
			
			
		<div class="inner-wrap">

			<div id="header-text-nav-wrap" class="clearfix">
				<div id="header-left-section">
											<div id="header-logo-image">
							<a href="https://www.chicitysports.com/" class="custom-logo-link" rel="home"><img width="147" height="120"   alt="CHI CITY SPORTS l Chicago Sports Blog &#8211; News &#8211; Forum &#8211; Fans &#8211; Rumors" data-src="https://www.chicitysports.com/wp-content/uploads/2020/01/20/cropped-cropped-chicitysportslogo2018_ab6a2d34c10e806b8f835e04c49aa5b7.png" class="custom-logo lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="147" height="120" src="https://www.chicitysports.com/wp-content/uploads/2020/01/20/cropped-cropped-chicitysportslogo2018_ab6a2d34c10e806b8f835e04c49aa5b7.png" class="custom-logo" alt="CHI CITY SPORTS l Chicago Sports Blog &#8211; News &#8211; Forum &#8211; Fans &#8211; Rumors" /></noscript></a>						</div><!-- #header-logo-image -->
											<div id="header-text" class="">
													<h3 id="site-title">
								<a href="https://www.chicitysports.com/" title="CHI CITY SPORTS l Chicago Sports Blog &#8211; News &#8211; Forum &#8211; Fans &#8211; Rumors" rel="home">CHI CITY SPORTS l Chicago Sports Blog &#8211; News &#8211; Forum &#8211; Fans &#8211; Rumors</a>
							</h3>
																		<p id="site-description">Chicago Sports Blog &#8211; Latest News, Discussion, &amp; Rumors for the Bears, Bulls, Blackhawks, Cubs, White Sox, and Fire.</p>
						<!-- #site-description -->
					</div><!-- #header-text -->
				</div><!-- #header-left-section -->
				<div id="header-right-section">
									</div><!-- #header-right-section -->

			</div><!-- #header-text-nav-wrap -->

		</div><!-- .inner-wrap -->

		
			
			
		<nav id="site-navigation" class="main-navigation clearfix" role="navigation">
			<div class="inner-wrap clearfix">
				
					<div class="home-icon">
						<a href="https://www.chicitysports.com/" title="CHI CITY SPORTS l Chicago Sports Blog &#8211; News &#8211; Forum &#8211; Fans &#8211; Rumors"><i class="fa fa-home"></i></a>
					</div>

					
									<div class="search-random-icons-container">
													<div class="top-search-wrap">
								<i class="fa fa-search search-top"></i>
								<div class="search-form-top">
									<form action="https://www.chicitysports.com/" class="search-form searchform clearfix" method="get">
   <div class="search-wrap">
      <input type="text" placeholder="Search" class="s field" name="s">
      <button class="search-icon" type="submit"></button>
   </div>
</form><!-- .searchform -->								</div>
							</div>
											</div>
				
				<p class="menu-toggle"></p>
				<div class="menu-primary-container"><ul id="menu-menu" class="menu"><li id="menu-item-49172" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49172"><a title="Chicago Sports Forum" href="https://www.chicitysports.com/forums/">Message Board</a></li>
<li id="menu-item-49173" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49173"><a href="https://www.chicitysports.com/contact/">Contact Us</a></li>
<li id="menu-item-49174" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49174"><a href="https://www.chicitysports.com/about/">About CCS</a></li>
<li id="menu-item-49195" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-49195"><a href="https://www.chicitysports.com/forum/forumdisplay.php/4-Chicago-Sports-Discussion">Team Forums</a>
<ul class="sub-menu">
	<li id="menu-item-49196" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49196"><a href="https://www.chicitysports.com/forum/forumdisplay.php/5-Chicago-Bears-Forum">Bears Team Forum</a></li>
	<li id="menu-item-49197" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49197"><a href="https://www.chicitysports.com/forum/forumdisplay.php/6-Chicago-Bulls-Forum">Bulls Team Forum</a></li>
	<li id="menu-item-49198" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49198"><a href="https://www.chicitysports.com/forum/forumdisplay.php/9-Chicago-Blackhawks-Forum">Blackhawks Team Forum</a></li>
	<li id="menu-item-49199" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49199"><a href="https://www.chicitysports.com/forum/forumdisplay.php/7-Chicago-Cubs-Forum">Cubs Team Forum</a></li>
	<li id="menu-item-49200" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49200"><a href="https://www.chicitysports.com/forum/forumdisplay.php/8-Chicago-White-Sox-Forum">White Sox Team Forum</a></li>
	<li id="menu-item-49201" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49201"><a href="https://www.chicitysports.com/forum/forumdisplay.php/35-Chicago-Fire-Forum">Fire Team Forum</a></li>
</ul>
</li>
<li id="menu-item-50657" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-50657"><a href="https://www.chicitysports.com/podcasts/">Podcasts</a></li>
<li id="menu-item-52851" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-52851"><a href="https://www.chicitysports.com/chicago-sports-schedule/">Chicago Sports Schedule</a>
<ul class="sub-menu">
	<li id="menu-item-52852" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-52852"><a href="https://www.chicitysports.com/chicago-sports-schedule/chicago-bears-schedule/">Chicago Bears Schedule</a></li>
	<li id="menu-item-52860" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-52860"><a href="https://www.chicitysports.com/chicago-sports-schedule/chicago-blackhawks-schedule/">Chicago Blackhawks Schedule</a></li>
	<li id="menu-item-52856" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-52856"><a href="https://www.chicitysports.com/chicago-sports-schedule/chicago-bulls-schedule/">Chicago Bulls Schedule</a></li>
	<li id="menu-item-52866" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-52866"><a href="https://www.chicitysports.com/chicago-sports-schedule/chicago-cubs-schedule/">Chicago Cubs Schedule</a></li>
	<li id="menu-item-52867" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-52867"><a href="https://www.chicitysports.com/chicago-sports-schedule/chicago-white-sox-schedule/">Chicago White Sox schedule</a></li>
</ul>
</li>
<li id="menu-item-53040" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-53040"><a href="https://chicitysports.myshopify.com/">ChiCitySports Shop</a></li>
<li id="menu-item-53201" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-53201"><a href="https://www.sportsbookreview.com/betting-odds/">Betting Odds</a></li>
</ul></div>
			</div>
		</nav>

		
		</div><!-- #header-text-nav-container -->

		
	</header>

		
	<div id="main" class="clearfix">
		<div class="inner-wrap clearfix">

	
	<div id="primary">
		<div id="content" class="clearfix">

			
				
<article id="post-54627" class="post-54627 post type-post status-publish format-standard has-post-thumbnail hentry category-other tag-gambling">
	
   
         <div class="featured-image">
               <img width="800" height="445"   alt="" data-src="https://www.chicitysports.com/wp-content/uploads/2020/02/12/Gambling-800x445.jpg" class="attachment-colormag-featured-image size-colormag-featured-image wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="800" height="445" src="https://www.chicitysports.com/wp-content/uploads/2020/02/12/Gambling-800x445.jpg" class="attachment-colormag-featured-image size-colormag-featured-image wp-post-image" alt="" /></noscript>            </div>
   
   <div class="article-content clearfix">

   
   <div class="above-entry-meta"><span class="cat-links"><a href="https://www.chicitysports.com/category/other/"  rel="category tag">OTHER</a>&nbsp;</span></div>
      <header class="entry-header">
   		<h1 class="entry-title">
   			The Best of the Best in Professional Betting   		</h1>
   	</header>

   	<div class="below-entry-meta">
			<span class="posted-on"><a href="https://www.chicitysports.com/2020/02/12/the-best-of-the-best-in-professional-betting/" title="2:19 PM" rel="bookmark"><i class="fa fa-calendar-o"></i> <time class="entry-date published" datetime="2020-02-12T14:19:01-06:00">February 12, 2020</time><time class="updated" datetime="2020-02-12T14:19:40-06:00">February 12, 2020</time></a></span>
			<span class="byline">
				<span class="author vcard">
					<i class="fa fa-user"></i>
					<a class="url fn n"
					   href="https://www.chicitysports.com/author/ned-d/"
					   title="CCS Staff">CCS Staff					</a>
				</span>
			</span>

							<span class="comments"><a href="https://www.chicitysports.com/2020/02/12/the-best-of-the-best-in-professional-betting/#respond"><i class="fa fa-comment"></i> 0 Comments</a></span>
			<span class="tag-links"><i class="fa fa-tags"></i><a href="https://www.chicitysports.com/tag/gambling/" rel="tag">Gambling</a></span></div>
   	<div class="entry-content clearfix">
   		<p>In the world of gambling, there are names and faces that stand out to even the most inexperienced of bettors. The industry is worth approximately £8 billion in the UK alone, meaning the professionals show no sign of revealing their secrets anytime soon. Some occasionally share small snippets of both their experiences and advice to their fans, while others are harder to scout out among the crowds. We compiled a list of the five best of the best in professional betting, who have made their fortunes from casino games, cashing out on the <a href="https://www.timeform.com/horse-racing/results/today">horse racing results</a> and sports betting.</p>
<h2>Zeljko Ranogajec</h2>
<p>Ranogajec is a 58-year-old businessman and professional bettor who’s estimated net worth is an impressive $600 million. The Australian gained his initial success through <a href="https://en.wikipedia.org/wiki/Blackjack">blackjack</a> but is now said to make the majority of his fortune through horse racing. Ranogajec is renowned for leading a very private life within the industry, some reports even stating that he uses a different name for certain gambling investments and wagers.</p>
<h2>Tony Bloom</h2>
<p>Nicknamed ‘the lizard’, Tony Bloom is known as one of the best in professional betting, being a <a href="https://en.wikipedia.org/wiki/Poker">professional poker player</a> and entrepreneur. Growing up in the same town, he is now the owner of the Brighton and Hove Albion Football Club, rumoured to have spent £250 million of his own money towards the club’s stadium and ground. Bloom has been known to have as much as £1 million riding on a single football match.</p>
<h2>Haralabos ‘Bob’ Voulgaris</h2>
<p>Voulgaris is renowned as one of the most well-known professional bettors in the world. Primarily gambling on NBA sports, he famously had a winning rate of 70% for five consecutive years before ultimately losing a third of his bankroll in one month in 2004. Bob is perhaps best known for his model ‘Ewing’, a tech model that simulates games based on statistics, ultimately launching him back into recurring wins through NBA bets.</p>
<h2>Ted Servansky</h2>
<p>Servansky, often referred to as Teddy ‘Covers’ is one of the more vocal gamblers within this list, providing regular insight into the world of sports betting to his listeners. The 50-year-old has featured multiple times in both printed press and news reports, speaking of his successes and business tactics, often referring to common mistakes that bettors can make and how to avoid them. Ted moved to Las Vegas in 1998 to bet on sports as a full-time profession, and has been doing so ever since.</p>
<h2>Billy Walters</h2>
<p>Billy Walters is arguably considered the ultimate sports bettor. At 73 years of age the professional gambler has an approximate net worth of US$100 million. Walters is regarded as one of the most successful sports bettors in the world, making a large amount of his fortune in Las Vegas. Using computer analysis to analyse sports results, Walters held an impressive 30-year winning streak through sports gambling, also winning £3.5 million on <a href="https://www.nfl.com/super-bowl">the Super Bowl</a> after betting on New Orleans Saints.</p>
   	</div>

   </div>

	</article>

			
		</div><!-- #content -->

      
		<ul class="default-wp-page clearfix">
			<li class="previous"><a href="https://www.chicitysports.com/2020/02/11/2020-pecota-projections-released-where-do-the-white-sox-stand/" rel="prev"><span class="meta-nav">&larr;</span> 2020 PECOTA Projections Released; Where Do the White Sox Stand?</a></li>
			<li class="next"><a href="https://www.chicitysports.com/2020/02/12/oilers-deliver-second-consecutive-loss-to-blackhawks/" rel="next">Oilers deliver second-consecutive loss to Blackhawks <span class="meta-nav">&rarr;</span></a></li>
		</ul>
	
      
      
      
<div id="comments" class="comments-area">

	
	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/02/12/the-best-of-the-best-in-professional-betting/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.chicitysports.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='54627' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="d3c730567e" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="189"/></p></form>	</div><!-- #respond -->
	
</div><!-- #comments -->
	</div><!-- #primary -->

	
<div id="secondary">
			
		<aside id="media_image-2" class="widget widget_media_image clearfix"><h3 class="widget-title"><span>Write for ChiCitySports!</span></h3><a href="https://www.chicitysports.com/contact/"><img width="290" height="143"   alt="" style="max-width: 100%; height: auto;" data-srcset="https://www.chicitysports.com/wp-content/uploads/2019/05/08/A0idSQ4.png 290w, https://www.chicitysports.com/wp-content/uploads/2019/05/08/A0idSQ4-250x123.png 250w" sizes="(max-width: 290px) 100vw, 290px" data-src="https://www.chicitysports.com/wp-content/uploads/2019/05/08/A0idSQ4.png" class="image wp-image-52594  attachment-full size-full lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="290" height="143" src="https://www.chicitysports.com/wp-content/uploads/2019/05/08/A0idSQ4.png" class="image wp-image-52594  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://www.chicitysports.com/wp-content/uploads/2019/05/08/A0idSQ4.png 290w, https://www.chicitysports.com/wp-content/uploads/2019/05/08/A0idSQ4-250x123.png 250w" sizes="(max-width: 290px) 100vw, 290px" /></noscript></a></aside><aside id="custom_html-3" class="widget_text widget widget_custom_html clearfix"><div class="textwidget custom-html-widget"><div class="stanzacal" data-stanzacal="chicitysports" data-site="chicitysports" data-width="300px" data-height="800px" ></div>
<script src="https://www.chicitysports.com/wp-content/themes/colormag/js/embed-stanzacal-v1.js" type="text/javascript" async></script></div></aside><aside id="custom_html-4" class="widget_text widget widget_custom_html clearfix"><h3 class="widget-title"><span>Shop and Support CCS!</span></h3><div class="textwidget custom-html-widget"><a target="_blank" href="https://shareasale.com/r.cfm?b=1377849&amp;u=1291289&amp;m=73502&amp;urllink=&amp;afftrack=" rel="noopener noreferrer"><img  border="0" data-src="https://www.chicitysports.com/wp-content/uploads/2020/01/17/PATCHJERSEY_CS_300x250_BEAR.jpg" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="https://www.chicitysports.com/wp-content/uploads/2020/01/17/PATCHJERSEY_CS_300x250_BEAR.jpg" border="0" /></noscript></a></div></aside><aside id="text-6" class="widget widget_text clearfix">			<div class="textwidget"></div>
		</aside>
	</div>
	

</div><!-- .inner-wrap -->
</div><!-- #main -->

	<div class="advertisement_above_footer">
		<div class="inner-wrap">
			<aside id="media_image-3" class="widget widget_media_image clearfix"><a href="https://sports.betway.com/en/sports"><img width="728" height="90"   alt="« Sports Betting Site Betway »" style="max-width: 100%; height: auto;" data-srcset="https://www.chicitysports.com/wp-content/uploads/2019/12/20/sports-betting-site-betway-728x90-1.jpg 728w, https://www.chicitysports.com/wp-content/uploads/2019/12/20/sports-betting-site-betway-728x90-1-300x37.jpg 300w, https://www.chicitysports.com/wp-content/uploads/2019/12/20/sports-betting-site-betway-728x90-1-250x31.jpg 250w, https://www.chicitysports.com/wp-content/uploads/2019/12/20/sports-betting-site-betway-728x90-1-550x68.jpg 550w" sizes="(max-width: 728px) 100vw, 728px" data-src="https://www.chicitysports.com/wp-content/uploads/2019/12/20/sports-betting-site-betway-728x90-1.jpg" class="image wp-image-54232  attachment-full size-full lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="728" height="90" src="https://www.chicitysports.com/wp-content/uploads/2019/12/20/sports-betting-site-betway-728x90-1.jpg" class="image wp-image-54232  attachment-full size-full" alt="« Sports Betting Site Betway »" style="max-width: 100%; height: auto;" srcset="https://www.chicitysports.com/wp-content/uploads/2019/12/20/sports-betting-site-betway-728x90-1.jpg 728w, https://www.chicitysports.com/wp-content/uploads/2019/12/20/sports-betting-site-betway-728x90-1-300x37.jpg 300w, https://www.chicitysports.com/wp-content/uploads/2019/12/20/sports-betting-site-betway-728x90-1-250x31.jpg 250w, https://www.chicitysports.com/wp-content/uploads/2019/12/20/sports-betting-site-betway-728x90-1-550x68.jpg 550w" sizes="(max-width: 728px) 100vw, 728px" /></noscript></a></aside>		</div>
	</div>



<footer id="colophon" class="clearfix ">
	
<div class="footer-widgets-wrapper">
	<div class="inner-wrap">
		<div class="footer-widgets-area clearfix">
         <div class="tg-footer-main-widget">
   			<div class="tg-first-footer-widget">
   				<aside id="text-5" class="widget widget_text clearfix">			<div class="textwidget"><p>ChiCitySports was founded in 2010 as a all-Chicago Sports blog and has grown into one of the largest Chicago Sports forums on the internet. We cover Chicago Sports the way the fan wants it covered.</p>
</div>
		</aside>   			</div>
         </div>
         <div class="tg-footer-other-widgets">
   			<div class="tg-second-footer-widget">
   				   			</div>
            <div class="tg-third-footer-widget">
               <aside id="recent-comments-3" class="widget widget_recent_comments clearfix"><h3 class="widget-title"><span>Recent Comments</span></h3><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">Ernie Kotsos</span> on <a href="https://www.chicitysports.com/2020/02/10/should-the-chicago-bears-take-a-serious-look-at-philip-rivers/#comment-231490">Should the Chicago Bears Take a Serious Look at Philip Rivers?</a></li><li class="recentcomments"><span class="comment-author-link">Al</span> on <a href="https://www.chicitysports.com/2020/02/11/2020-pecota-projections-released-where-do-the-white-sox-stand/#comment-231425">2020 PECOTA Projections Released; Where Do the White Sox Stand?</a></li><li class="recentcomments"><span class="comment-author-link">Bill Maletich</span> on <a href="https://www.chicitysports.com/2020/02/05/the-portillos-beef-bus-food-truck-is-hitting-the-road-across-america/#comment-231153">The Portillo’s ‘Beef Bus’ Food Truck is hitting the road across America</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://Google' rel='external nofollow ugc' class='url'>Jon Woolsey</a></span> on <a href="https://www.chicitysports.com/2020/01/25/legendary-horses-in-the-history-of-kentucky-derby/#comment-230696">Legendary Horses In The History Of Kentucky Derby</a></li></ul></aside>            </div>
            <div class="tg-fourth-footer-widget">
               <aside id="linkcat-2" class="widget widget_links clearfix"><h3 class="widget-title"><span>Links</span></h3>
	<ul class='xoxo blogroll'>
<li><a href="http://www.beargoggleson.com">BearGogglesOn</a></li>
<li><a href="https://www.chicitysports.com/forum/forumdisplay.php/5-Chicago-Bears-Forum" title="Chicago Bears Fan Message Board">Bears Message Board</a></li>
<li><a href="http://www.bigtimegameboards.com/" title="Quality Custom Cornhole Boards">BigTimeGameBoards.Com</a></li>
<li><a href="https://www.chicitysports.com/forum/forumdisplay.php/9-Chicago-Blackhawks-Forum" title="Chicago Blackhawks Fan Message Board">Blackhawks Message Board</a></li>
<li><a href="https://www.chicitysports.com/forum/forumdisplay.php/6-Chicago-Bulls-Forum" title="Chicago Bulls Fan Message Board">Bulls Message Board</a></li>
<li><a href="http://www.reddit.com/r/chibears" title="Reddit&#8217;s Chicago Bears Community">Chicago Bears on Reddit</a></li>
<li><a href="http://www.chicagotribune.com/sports/">Chicago Tribune Sports</a></li>
<li><a href="http://www.chitownclothing.com" title="Chicago Sports Clothing. ">Chitown Sports Clothing</a></li>
<li><a href="https://www.chicitysports.com/forum/forumdisplay.php/7-Chicago-Cubs-Forum" title="Chicago Cubs Fan Message Board">Cubs Message Board</a></li>
<li><a href="http://www.dabearnecessities.com/">Da Bear Necessities</a></li>
<li><a href="https://www.chicitysports.com/forum/forumdisplay.php/35-Chicago-Fire-Forum" title="Chicago Fire Fan Message Board">Fire Message Board</a></li>
<li><a href="http://www.gamedaychitown.com">GameDay Chitown</a></li>
<li><a href="https://www.chicitysports.com/forum/forumdisplay.php/8-Chicago-White-Sox-Forum" title="Chicago White Sox Fan Message Board">White Sox Message Board</a></li>

	</ul>
</aside>
            </div>
         </div>
		</div>
	</div>
</div>	<div class="footer-socket-wrapper clearfix">
		<div class="inner-wrap">
			<div class="footer-socket-area">
				<div class="footer-socket-right-section">
									</div>

				<div class="footer-socket-left-section">
					<div class="copyright">Copyright &copy; 2020 <a href="https://www.chicitysports.com/" title="CHI CITY SPORTS l Chicago Sports Blog &#8211; News &#8211; Forum &#8211; Fans &#8211; Rumors" ><span>CHI CITY SPORTS l Chicago Sports Blog &#8211; News &#8211; Forum &#8211; Fans &#8211; Rumors</span></a>. All rights reserved.<br>Theme: ColorMag by <a href="https://themegrill.com/themes/colormag" target="_blank" title="ThemeGrill" rel="author"><span>ThemeGrill</span></a>. Powered by <a href="https://wordpress.org" target="_blank" title="WordPress"><span>WordPress</span></a>.</div>				</div>
			</div>
		</div>
	</div>
</footer>

<a href="#masthead" id="scroll-up"><i class="fa fa-chevron-up"></i></a>

</div><!-- #page -->
  <!-- VigLink: http://viglink.com -->
  <script type="text/javascript">
    var vglnk = { key: 'ff3e699c7a374298785f40574a4881a5' };

    (function(d, t) {
      var s = d.createElement(t); s.type = 'text/javascript'; s.async = true;
      s.src = '//cdn.viglink.com/api/vglnk.js?key=' + vglnk.key;
      var r = d.getElementsByTagName(t)[0]; r.parentNode.insertBefore(s, r);
    }(document, 'script'));
  </script>
  <!-- end VigLink -->
<script>
    jQuery(document).ready(function () {
		jQuery.post('https://www.chicitysports.com?ga_action=googleanalytics_get_script', {action: 'googleanalytics_get_script'}, function(response) {
			var s = document.createElement("script");
			s.type = "text/javascript";
			s.innerHTML = response;
			jQuery("head").append(s);
		});
    });
</script><script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.chicitysports.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.chicitysports.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.6'></script>
<script type='text/javascript'>
window.lazySizesConfig = window.lazySizesConfig || {};

window.lazySizesConfig.lazyClass    = 'lazyload';
window.lazySizesConfig.loadingClass = 'lazyloading';
window.lazySizesConfig.loadedClass  = 'lazyloaded';

lazySizesConfig.loadMode = 1;
</script>
<script type='text/javascript' src='https://www.chicitysports.com/wp-content/plugins/wp-smushit/app/assets/js/smush-lazy-load.min.js?ver=3.4.2'></script>
<script type='text/javascript'>
lazySizes.init();
</script>
<script type='text/javascript' src='https://www.chicitysports.com/wp-content/themes/colormag/js/jquery.bxslider.min.js?ver=4.2.10'></script>
<script type='text/javascript' src='https://www.chicitysports.com/wp-content/themes/colormag/js/navigation.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://www.chicitysports.com/wp-content/themes/colormag/js/news-ticker/jquery.newsTicker.min.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://www.chicitysports.com/wp-content/themes/colormag/js/sticky/jquery.sticky.js?ver=20150309'></script>
<script type='text/javascript' src='https://www.chicitysports.com/wp-content/themes/colormag/js/fitvids/jquery.fitvids.js?ver=20150311'></script>
<script type='text/javascript' src='https://www.chicitysports.com/wp-content/themes/colormag/js/skip-link-focus-fix.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://www.chicitysports.com/wp-content/themes/colormag/js/colormag-custom.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://www.chicitysports.com/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
<script async="async" type='text/javascript' src='https://www.chicitysports.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.3'></script>
</body>
</html>
